First post with ScribeFire

At this time (in order to write this post) I’m using ScribeFire (plugin for Firefox). Initially an issue related to OAuth was making impossible to use this plugin.
The cryptic error was (scribefire bad login) :

Well, this is embarrassing…
ScribeFire couldn’t get the information it needed about your blog. Helpfully, your blog returned this message: Bad login/pass combination.

I solved this issue editing manually all fields in order to avoid to use OAuth.

How to solve the issue

When you use the wizard “Add a New Blog” it allows to you to insert just the URL of your blog and all remaining fields are filled automatically.

Add Blog

Blog Type and  API URL are filled automatically and username/password authentication is replaced by OAuth steps : app has to be authorised on wordpress site. The issue is that if you try to use OAuth pressing the button “Click to securely authorize ScribeFire” (see below image) then you get the following error message.

Click to securelly authorize ScribeFire

Authorize

ScribeFire error message

In order to solve this issue you have to edit manually each field :
 URL
 http://test.wordpress.com/ btw don’t press next but continue to fill all remaining fields
 Blog Type
  WordPress
API URL
  such as URL but with xmlrpc.php ex. http://test.wordpress.com/xmlrpc.php

In this way instead of button “Click to securely authorize ScribeFire” ScribeFire shows to you two fields where to insert username/login.

 


Now some tests

1. drag&drop image from desktop

2. table

cell (1,1) Cell (1,2)
cell (1,2)

3. rich text styles

ABCDEFABCDEFABCDEFABCDEFABCDEFABCDEFABCDEFABCDEFABCDEF
ABCDEFABCDEFABCDEFABCDEFABCDEFABCDEFABCDEFABCDEFABCDEF

4. Code

#!/bin/sh
#Config
 LOCAL_PATH=/mnt/usb_storage/shared/0_UnderBackup/
 REMOTE_PATH=/mnt/disk1/share/0_backupBigGnomo/
 REMOTE_IP=192.168.2.2
 SCRIPT_PATH=/mnt/usb_storage/shared/script/
 FROM=BigGnomo@home.it
 TO=my.name@gmail.com
 SERVER=smtp.server.it
#Backup
 rdiff-backup --print-statistics $LOCAL_PATH $REMOTE_IP::$REMOTE_PATH >/tmp/last_backup.txt 2>/tmp/last_backup_E.txt
#Prepare Notify
 sed s//"`date`"/ $SCRIPT_PATH/template.tpl >/tmp/email.txt
 cat /tmp/last_backup.txt >>/tmp/email.txt
 cat $SCRIPT_PATH//help.txt >>/tmp/email.txt
#Send notify
 cat /tmp/email.txt | sendmail -f$FROM -s$SERVER $TO#Error : check error looking into --print-statistics file (/tmp/last_backup.txt)
 error=`grep -e 'Errors.0' /tmp/last_backup.txt`
 if [ -z "$error" ]; then
 sed s//"`date`"/ $SCRIPT_PATH/template_error.tpl >/tmp/email_e.txt
 cat /tmp/last_backup_E.txt >>/tmp/email_e.txt
 cat /tmp/email_e.txt | sendmail -f$FROM -s$SERVER $TO
 fi

5. youtube link

[youtube http://www.youtube.com/watch?v=8reugc_rSak&w=420&h=315]

Works only embed code provided for your video.

6. Recovery from crash

OK! works

7. update posts

OK works!

8. some tests

WARNING:

 eeeeee eeeeee eeeeee eeeeee eeeeee eeeeee eeeeee eeeeee eeeeee
ADDRESS,
BLOCKQUOTE,
BODY, DD, DIV,
DL, DT,
FIELDSET, FORM,
FRAME, FRAMESET,
H1, H2, H3, H4,
H5, H6, IFRAME,
Powered by WP Review
Tags

1 Comment

Click here to post a comment

This site uses Akismet to reduce spam. Learn how your comment data is processed.

  • I was wondering how to fix this and I was so happy to find this post.

    I’m sure others were having this problem and I’m not too afraid to say that the extensions maker definitely made a huge mistake by not allowing one to manually sign in.

Posts